The software implements a DHCP/BOOTP Server based on RFC 2131. Besides the standard dynamic IP address assignment for clients the software supports the assignment of predefined profiles and static IP addresses to known hardware addresses or identifiers.
The server includes a multithreaded TFTP server for secure and reliable downloads.
The server supports all DHCP/BOOTP options and has no limitation in the number of clients. On multi homed servers the software can handle up to 32 interfaces with one dynamic IP address pool per interface IP address.
User interface in English and German.
Address and parameter assignment can be based on:
hardware address
hardware address range (e.g. vendor bytes of MAC address)
Server interface
Client identifier
Vendor or User class (as specified in RFC 3004)
Relay IP address
Relay Agent Information (as specified in RFC 3046) including support of normal and trusted server interfaces.
The DHCP Server is implemented as a native service for background operation, A Control Panel applet provides interactive access to the service.
haneWIN DHCP Server is proprietary software from haneWIN Software. Check the publisher's license terms for pricing and usage rights.
What is the latest version of haneWIN DHCP Server?
The latest version is 3.1.28.1, released on Sep 11, 2025.
Is it safe to download haneWIN DHCP Server?
The download button links to the official installer published on r.hanewin.net, the same file Windows Package Manager installs. You can verify the downloaded file by comparing its SHA-256 checksum with 5a5a2df2a9ed667a99d5050ee0b7cc168445cc8dd5aef873039228e250620180.
Which Windows versions does haneWIN DHCP Server support?
haneWIN DHCP Server runs on Windows and is available for 32-bit (x86) systems.
How do I install haneWIN DHCP Server silently?
Run the offline installer with "dhcp3128.exe" /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-, or install it with Windows Package Manager: winget install --id=haneWIN.DHCPServer -e --silent.
How do I uninstall haneWIN DHCP Server?
Open Settings › Apps › Installed apps, find haneWIN DHCP Server and select Uninstall. From the command line, run winget uninstall --id=haneWIN.DHCPServer -e.
Chocolatey is The Package Manager for Windows. It was designed to be a decentralized framework for quickly installing applications and tools that you need. It is built on the NuGet infrastructure and
Dell Command Update is a stand-alone application for systems that provides updates for system software that is released by Dell. This application simplifies the BIOS, firmware, driver, and application