About PeerBanHelper
Automatically ban unwanted, leeching and abnormal BitTorrent clients with support for customized rules.
Automatically ban unwanted, leeching and abnormal BitTorrent clients with support for customized rules.
Automatically ban unwanted, leeching and abnormal BitTorrent clients with support for customized rules.
修复安全漏洞
- Orderable 查询可能传入 SQL 注入语句的问题 GHSA-vpxv-cm55-rwf7 @Ghost-chu 鸣谢:@tonghuaroot
新功能
- NAT64 地址支持 @Ghost-chu
- 目前默认支持 WKP 的 NAT64 地址。由于无法可靠探测某个网络是否为 NAT64 网络,因此如果您正在使用 NSP 的 NAT64 地址,请手动编辑配置文件。
- 新的 webhook 通知渠道 @gongfuture
错误修复
- 封禁列表重映射未正确处理 Teredo 地址 @Ghost-chu
- 修复在较新的 DSM 上,安装 PeerBanHelper 可能出现错误的问题 @Ghost-chu
开发者更改
- PeerAddress 现在包含新的 teredoClientIp 和 teredoClientUdpPort 字段,指示 Teredo 有关的 IP 元数据
- PeerAddress 的 nattedIp 和 nattedPort 除原 AutoSTUN 地址转换使用外,现在 NAT64 地址转换也将会更新这些字段。
- 现在规则检查模块无需为了转换 ::ffff: 地址进行刻意的 isIPv4Convertible 检查,PeerBanHelper 现在统一处理这些转换。这包括:Well-Knowned NAT64 地址(RFC-6146, RFC-6052)、Teredo 地址(RFC-4380, RFC-5991)、IPv4-mapped IPv6 地址(RFC-4291, RFC-4038)
Docker
DockerHub: ghostchu/peerbanhelper:v9.5.1
阿里云国内镜像加速:registry.cn-hangzhou.aliyuncs.com/ghostchu/peerbanhelper:v9.5.1
部署教程 | 常见问题 | 如何设置下载器 | PBH-BTN 论坛
| Publisher | PBH-BTN Community |
|---|---|
| Version | 9.5.1 |
| Release date | 2026-09-01 |
| License | GPL-3.0 |
| Installer type | exe |
| Architecture | x64, arm64 |
| Package ID | PBH-BTN.PeerBanHelper |
Install PeerBanHelper from the command line with Windows Package Manager (winget):
winget install --id=PBH-BTN.PeerBanHelper -e